Axis Label Clipping

May 12, 2011 at 9:28 PM

I am using the D3 future library, and am having trouble with label clipping.  I found this article here, which describes a similar problem but for a previous build of D3.  

 

Is there a quick way to disable clipping?  I have tried using IsStaticAxis, but the results are not what I want, since I have a small drawing area with many labels, causing them to overlap.

 

Thanks,

Stuart

May 13, 2011 at 7:25 PM

I figured it out, although it involved changing the source for D3.  In the AxisControlStyle.xaml file, the first property is setting the property "Grid.ClipToBounds".  Ensure that this property is set to False.  Also in the AxisControl.cs class, make sure the constructor does not set ClipToBounds to True.  This only seemed to happen in some of the source versions.

 

If anyone has a way of doing this that does not involve changing the source, let me know.

 

-Stuart