Getting Started...

Oct 10, 2011 at 11:35 PM

I feel a bit dense posting this, but I can't make heads nor tails of what I'm doing wrong.

<Window x:Class="DataMonitor.MainWindow"
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:d3="http://research.microsoft.com/DynamicDataDisplay/1.0" 
        Title="Data Monitor" WindowState="Normal" Height="350" Width="525">
    <Grid>
        <d3:ChartPlotter Name="plotter"></d3:ChartPlotter>
    </Grid>
</Window>

The above is the entire extent of my WPF window. I'm stuck here because I get the error, "The type 'd3:ChartPlotter' was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been built."

I have downloaded D3, placed the DynamicDataDisplay in my solution folder, and added the DynamicDataDisplay.dll as a reference in the project. I've been using http://msdn.microsoft.com/en-us/magazine/ff714591.aspx as a guide.

I must be doing something that's really obviously wrong, but I can't figure it out. Any help? Did I miss a step in setting the project up?

Oct 10, 2011 at 11:50 PM

Did you type in

xmlns:d3="http://research.microsoft.com/DynamicDataDisplay/1.0" 

 or browse for the assembly by typing

xmlns=

and then selecting from the intellisense list?

 

After doing that, if you type

<d3:

does an intellisense list of components popup?

 

Is ChartPlotter in the list?

Oct 11, 2011 at 12:37 AM

Copy/pasted it. And it doesn't appear in the IntelliSense list, so I guess that's where my problem lies. Are there any other references I need to add? Or what?

Your quick response is extremely appreciated. Thank you.

Oct 11, 2011 at 12:45 AM

Do the D3 samples compile/run?

 

Do they have 

xmlns:d3="http://research.microsoft.com/DynamicDataDisplay/1.0" 

in their xaml?

Oct 11, 2011 at 1:05 AM

Unfortunately, the samples I have are only the .dll's and the .exe's - no code.

Oct 11, 2011 at 1:51 AM

I recommend you change to using the latest source code from http://dynamicdatadisplay.codeplex.com/

I've used that version for a long time without significant issues.

The main problem with either version is that development has stopped (but it's still the best wpf graph library for large data sets).

Oct 11, 2011 at 3:03 PM

Oh my, I thought I had the most recent version.

The samples in the most recent version don't work, either. For example, the Coastline Sample has the warnings:

  1. The referenced component 'DynamicDataDisplay.Coastline' could not be found.
  2. The referenced component 'DynamicDataDisplay' could not be found.

So it's not finding ChartPlotter, either. When I look under the "references" folder in the project (in the solution explorer), and view the properties of DynamicDataDisplay and DynamicDataDisplay.Coastline, the "path" field is empty. I also tried typing "xmlns:d=" to see what popped up, and the research.microsoft.com doesn't show up (that specific line does already exist in the xaml).

Excuse me for perhaps being a bit dense, but do I need to make/generate the .dll files? Since I notice there's no .dll files in the stable version.

Oct 11, 2011 at 3:33 PM

Wait... I got samples working. And found the .dll in the stable release.

I tried referencing the same .dll the samples were in my project, but I still don't get anything.

I'm so completely confused and frustrated. I feel like this ought to be simple, but I can't get it working.

Oct 11, 2011 at 5:41 PM

Well. I got it working well enough. At least for the moment.

I added the DynamicDataDisplay project to my solution, built the solution, and then added the DynamicDataDisplay project as a resource to my project.

Oct 3, 2013 at 11:38 AM
Hi, Can i ask you how did you get the code working? which process you did? and which source code you used?
Oct 3, 2013 at 1:16 PM
Too strange i did the same as you did,, first it did not work for several times, and than it started to work :) anyway, thanks for info sharing..
Sep 16, 2014 at 2:51 PM
The strange thing is I have the same error. But I just start the project and it happens working properly...
Sep 17, 2014 at 6:27 AM
Aug 13, 2015 at 3:23 PM
We have faced the same problem. We have download the latest source code "d3future-399ef19cd344".
After opening the example project and try to complier and always get the error "The type 'd3:ChartPlotter' was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been built."

It took a half day to figure out what is real problem.
We found that all DynamicDataDisplay dlls are target/build with .NET 4.0 and the example project are target/build with .NET 3.5.
After we change example project targets to .NET 4.0 and build, the problem goes away. Hope this finding will help.